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BEST PRACTICES COURSE – WEEK 21 – Creating and Customizing 
Library Parts PART 9 - Custom Drawing Titles 
 

Hello, this is Eric Bobrow. In this lesson, we will take a look at how you create your own custom drawing 

title. I will draw a very simple box of walls just to give myself some context. Put in a door and a window 

and then jump out to the first floor plan sheet. Select this drawing here; and I will use the pet palette to 

crop the drawing around to match the building better. [0:00:37] 

Now here is the default drawing title that is set up in the U.S. version of the template. With the drawing 

selected, I can switch from one title to another. For example, I can switch from the "NCS Drawing Title 

16" to the variation called "NCS 2". You can see how it's changed. Or the "Simple Title" or the built in 

"Drawing Title". Now depending on what version of ArchiCAD you have - ArchiCAD 10, 13, 14, 16, 

whatever - this may vary; and also between the U.S. and other national versions. [0:01:15] 

But let's say that I wanted something similar to this but I wanted to put a box around the number here 

and have a word "scale" here. I have had people ask me, "How can I make it just the way I want it?" 

 Well, this is configurable. So there are some options here if we go into the drawing settings and open 

up the Title panel of the drawing settings. You will see that there are some options for whether or not to 

show the drawing name here. And we can look at the font size and drawing scale. There are some 

options here. [0:01:55] 

But I can guarantee that there are some things that just aren't possible. For example, I will demonstrate 

a different version. This will give you an idea of how to create any type of drawing title you want. Now I 

am on a layout sheet here, in the layout environment. And I'm going to create something that looks 

similar to this drawing title, but just varying it the way that I would like to. So I am going to go to the Line 

tool and draw a little line, but I don't want it to be long. Let's just make sure it's a straight line and not a 

box here. I don't want it to be as long as this one up above; I just want it to be a little piece. [0:02:45] 

Go to the Text tool and zoom in a little bit and I will put in text. Now if I am going to be putting in a 

number here, perhaps it may sometimes be two digits or a letter and a digit. So I'll just put in a couple of 

digits to make sure that I am doing a placeholder that is big enough. Now I would like it to be a little bit 

larger text, so I will make it 12pt. and I will drag this up into position. [0:03:12] 

So I am basically creating a mockup of what I'd like this to be. And then I will go and create another text 

item. That will be just "name", this is going to be where the drawing name is going to be placed. And I 

will change this also to be a similar size so it matches. I will drag this up into position. Now if I want it to 

be centered along here, then I will drag it from this center point and perhaps find the center point of 

this line and drag it up straight using the Shift key into some reasonable position. [0:03:48] 
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But if I were to edit this text and add more text, if I were to type something like additional text, you see 

how it goes off to the right. So it doesn't stay centered. In order to keep it centered, what I need to do is 

before I create it or afterward, have the text selected and change its anchoring. So I am going to change 

the anchor to be let's say center, center. [0:04:14] 

That means that as it gets bigger or smaller, it will just keep that center point the line. Now, having done 

that, if I were to put in more text then you can see how the center point stayed the same. You can see 

how if I delete this it keeps the center there. So center alignment is what I want. On the other hand, the 

text that I put on the right side here I want it to be right aligned. And I also do want it to be this smaller 

size, let's say the 7pt text here. [0:04:43] 

So I will just go in and type in "scale". And I will type in a placeholder of the text. So I will say 1/4 '=1'0". 

Now if you were working in metric, you may say 1:50 or something like that. Now this text I would like to 

be aligned on the right side so that it looks this way. And I will drag this now up into a position here in 

relationship to this line. Now if the scale got bigger - and of course it's not going to vary much in terms 

of characters - but if it did get bigger, we would want it to stay locked on the right side. [0:05:28] 

So I am going to go ahead and anchor it on the right here. And this text here, now that we are doing it, I 

would like it to stay anchored to the center. So if it has only a single digit, it will be centered on that; and 

if it's double digits, it will be centered around that. So let me lock it in there. If I want to make these a 

little neater, perhaps I will select all of them and use the Edit>Align. Align the bottom, and now they are 

all neatly aligned. I think that will do just fine. [0:06:03] 

Now I am going to select all of them, the text and the line, and go to the File>Libraries and Objects>Save 

Selection As…Drawing Title. Now this may look slightly different on different versions of ArchiCAD, but 

you are going to be looking for saving it as a drawing title. In doing that, I'm going to give it a name, say 

"Custom Title 1". And it's now been saved into the embedded library. If I select this particular drawing or 

any drawing, I can now switch it to use that new custom title which appears in the list. [0:06:42] 

 You can see how it now looks exactly like what I had set, but it's not smart, it actually has just the word 

"Name". It doesn't have the drawing title or number properly. Now I can move this into a new position. I 

can grab it here and you can see with the pet palette I can grab the title and move it into a new 

relationship. But by default, it just went into the bottom left corner. [0:07:05] 

Let's make this smarter. So I am going to go into this text and we'll highlight it. And instead of having 

text that I type in, I am going to use the Auto text feature here. The Auto text allows me to pull 

information about project or about the system, for example, the date and time, things like that. But in 

this case, I want information about the drawing that is going to be linked to this title. So I want the 

drawing name here. And you can see how it's put in the placeholder, in this case, the name of the 

drawing that is on this sheet. [0:07:37] 
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It will actually change depending on what drawing it's attached to. For this text, again I am going to edit 

it and replace all that text with the drawing ID here. Then we will go this text here and in this case, I 

don't want to change the word scale. That's going to stay fixed. But this particular drawing scale, I am 

going to change it to an automatic representation of whatever it's supposed to be. And let's actually add 

the lines around here. [0:08:10] 

I wanted a little box. Now make a note that you can use the Line tool or Arc tool, but you cannot use the 

Poly Line tool for this purpose. It just will not actually work with the drawing title. So I can draw a box of 

lines rather than a poly line. So I will just draw a box like this that will be big enough for two characters. 

And now I will select all of these and go to File>Libraries and Objects>Save Selection As…Drawing Title. 

[0:08:41] 

And in this case, I want to overwrite the original one, the "Custom Title 1". It asks me if I want to replace 

it, and I say yes. We didn't see a change here, but if I zoom in or out, this will update. It basically needed 

to refresh the screen. And you can see how it is now showing the proper name of this drawing. If we 

were to change the name of the drawing, I will select this and give it some different words, you can see 

how the text automatically gets added. [0:09:24] 

So this title here may not be good if we have a longer name, but it certainly will work for shorter ones. 

And that's one of the issues with creating a custom drawing title is that it will be a fixed representation, 

even if certain things are smart like this, it will be fixed. So what would happen if you wanted to use this 

on a detail sheet? So I will go to the detail sheet and create a new layout here using one with a grid and 

put a drawing on an elevation here. So I will just drag this onto the sheet. [0:10:14] 

And you can see here is our view of the building. So this view here is straddling two cells. Let me go 

ahead and arbitrarily fit it within one. So imagine that this is a detail drawing. Now this is using a title 

that was built in, one of the ones that is the default. That changes from the built in drawing title to my 

custom title. You can see how it does correctly indicate the name of the drawing and the scale. And I can 

go ahead and move this title down. [0:10:50] 

Now if I wanted to have a title for a drawing that fit across, let's say that I wanted it to go across two 

cells, then I would create a variation of that. So here is how I am going to demonstrate that. I am going 

to go back to the original elements here, copy them, and perhaps I will go back to the other sheet that I 

was just working on, this one here, and I will paste this in. [0:11:20] 

The reason I am doing this is to visualize this in the context. So I want to basically make it so that it fits 

across two cells. So one way that we can do this is to use the Marquee tool, draw a box around the end, 

and then click on one point and drag it across using the guideline to keep it straight. And perhaps I need 

to move it a little bit further to get it to the size that I feel would be best. [0:11:51] 
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So now that text there is lined up on the right side. I want to make sure that the text that is going to be 

the title is centered, so I will just snap it into place. So the center of this snaps to the center of that line 

there. That's close enough for what we need right now. So I will select these here and go to the 

File>Libraries and Objects>Save Selection As…Drawing Title. And we will just name it with the "Custom 

Title 2".  [0:12:24] 

And now, for any drawing, if I select this I can switch to Custom Title 2. And you can see how it now has 

the longer version, which I can reposition using the pet palette as needed. So for ones that would be 

straddling three of four cells in this particular idea, you would need to create three or four variations of 

that, as many as you need.  So you are able to get smart text for the ID, name and scale. [0:13:05] 

And I'll demonstrate. If I were to change this scale here, let's change it and make it a little bigger. So 3/8' 

to 1'. So you can see how that's made it bigger, and this has now actually changed scale. So it 

automatically updated to show the correct scale. And we already saw how it would work if we were to 

change the name of the drawing. And likewise, if we were to move this drawing over into a different 

cell, then you can see as I zoom in or out that this will update because we are now picking up the name 

of that particular cell. And of course I might want to move this into a proper relationship so that it's 

straddling these two cells here. [0:13:52] 

This concludes our lesson on creating custom titles. You'll see how you can create any type of graphic 

that you want and it's somewhat smart picking up the name and ID and scale, but if you need to have 

different lengths of the line, then you would have to create multiple variations of the drawing title. Now 

these drawing titles live within the current project because I embedded them. You can see they show up 

in the options for drawing titles here. [0:14:25] 

If you later wanted to export them or use them in another project, you can go to the File menu>Libraries 

and Objects>Library Manager. And what we will see is here are these two titles. We can use the option 

to save the embedded sub tree into a local folder. And that will save either one of the parts or all of 

them into a folder on your hard drive. And then you can add it and embed it into other projects or load 

that folder that as a linked library so that they are available. So any titles that you make in one project 

can then be made available in another project. [0:15:08] 

So this has been Eric Bobrow. I look forward to seeing your comments and questions on the page down 

below. Thanks for watching.  

[END OF AUDIO 0:15:17] 

  


