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BEST PRACTICES COURSE – WEEK 21 – Creating and Customizing 
Library Parts PART 8 - Rotating and Tilting Objects 
 

Hello, this is Eric Bobrow.  In this lesson, we'll take a look at how you can rotate and tilt objects in ways 

that help you to model things that otherwise would be difficult.  I will just draw a box of walls to get 

started here and pop in a door. [0:00:17] 

Now, when I place this door here, I can go and look at the different styles.  So for example, in terms of 

the door panel, if I choose an ornate style - now one of the issues here is that the casing around the 

door is very simple.  It's not going to really match the door.  So let's just take a look here in an 

axonometric view and zoom in on it.  So we have a door that has some detail here, but this casing is very 

simple. And really, it would be nice to be able to put a more ornate casing on there. [0:01:01] 

So what I'm going to do is turn off the casing on this door, and we'll replace it with something that we'll 

model and put into position.  So in here I'll go into the general settings and I'll turn off the casing entirely 

so we can replace it with something that we put in manually.  So we've got the jamb, but we don't have 

the casing there.  So when we create this casing, we'd like to use a molded shape.  So I'm going to bring 

in a molding shape from the library.  [0:01:36] 

So if I go to the Object tool and search for casing here, we'll see that there are a number of 2D forms.  

This is in the U.S. library. I'm not sure whether they exist in all of the Graphisoft versions, but it doesn't 

really matter.  You can draw the shape yourself or import it from the manufacturer's catalog. In this case 

I'm using it just for convenience to bring in a form that will represent this type of geometry.  [0:02:07] 

So if I place this element here, you can see that it's just a 2D symbol.  And I'll go and explode it.  So we'll 

go to the Reshape menu here and explode into current view.  And it's now actually created a copy of a 

line work plus the element.  I'll just drag the element of the way here.  And you can see that here is the 

actual object, and these are lines from the actual graphic.  So I'm going to get rid of these lines here, and 

there's another little piece there.  And I'll use the Fill tool and magic wand here to create this shape.  

[0:02:57] 

So this is a fill that just has the same shape as the original object here.  And I'll copy it, and we'll go to 

our Design menu to Complex Profiles, Profile Manager.  And I will create a new profile.  So with profiles, 

we can go ahead and simply say New Profile here and paste.  And I will then move this into position and 

zoom in on it.  Now the origin point in this window is going to become the reference line for the 

element.  If I'm putting this casing around the door, then I might want to have this point in line with the 

door opening so that the thickness of the element then goes away from the door.  In other words, it 

goes outside the door rather than coming inside. [0:03:53] 
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Of course I may want to have this be offset a certain distance from the actual rough opening.  But for 

now, for our purposes, we will set it exactly on top of the rough opening, this corner point here.  For our 

purposes, we don't need to do much more, we just need to make sure that this fill here has certain 

settings for the material so it doesn't distract.  We will go and take this just a simple white paint color 

here for that.  I think that will be good.  We'll say we'd like to use it for walls, columns, and beams, 

because we are going to be using this for some modeling that will require using it for columns and 

beams.  And we could use it for walls, and we will see how that works. [0:04:46] 

I will store the profile here, and we will call this "Casing 1".  This is now going to be in our library of 

forms that we can use with walls, beams and columns.  Now when I go back to the floor plan and I go 

and zoom out a little bit here, and we go to the edge of this door, I could go in and put in a column.  So 

something that would stand up vertically next to the door that would create that casing.  And I will close 

the profile manager; we don't need to refer to it at this point.  I'm going to choose that this column is 

going to have a profile shape. [0:05:29] 

I will select from the profile shapes the casing.  Let me just scroll this over a little bit so that it stays 

within the recording area.  So here you can see the casing shape that I've just selected and created.  

Now the casing shape that I've got here has a certain height.  The door - let's just check the door here. If 

I select the door, it says that it's 6' in height.  So a little over 2 meters.  So I'm going to make the column 

the same thing, 6'8" here.  And let's look at the other settings for this column.  [0:06:20] 

On the plan, we don't want to crosshair, we just want a plain shape on that.  We probably don't have to 

worry too much about this.  I will go ahead and click to place it.  And when I click to place it you can see 

that this shape is actually mirrored from what I need.  Let me go and select this and I will mirror this 

across the face of the wall.  And now you can see we've got that shape.  Now if I go back to 3D, we are 

going to see here is the shape.  I will zoom in a little bit on it, and you can see the shape that you would 

expect from the profile that I was using. [0:07:08] 

I will take this element and mirror a copy of it across the center line of the door.  So let me just find a 

snap point that is the center line of the door.  You can see now I have two of them.  I will go ahead and 

create a beam so it will go across the top of the door horizontally, and I will again choose a profile here.  

And we'll go and choose that casing shape.  Just draw it across.  Now let's take a look in 3D and see what 

we've got.  [0:07:50] 

So the beam is a little high and it's sticking into the wall here.  So I'll go ahead and maybe take that beam 

and again we'll mirror this across the face of the wall.  And now we'll take a look at that.  And perhaps 

from an elevation view we will drag it down into position.  So what do we have?  I will drag this down.  It 

looks like that shape is actually facing the wrong way.  It's not lying against the wall; it's sticking out from 

the wall.  If I go to 3D and zoom in on it, we can see that we've got that shape, but it's facing the wrong 

way. [0:08:45] 
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So I will need to create a different version of the casing.  Let's go into our Design menu, Complex 

Profiles, Profile Manager.  And we will go and open up that Casing 1 and edit it.  And then we will 

actually rotate this to be in a different orientation.  So if the actual profile, now that I've gotten used to 

it, if I were to mirror this, that is going to be the best way for the columns to be.  I will store this and fix 

the ones that I've already put in. [0:09:26] 

This is the way that they would actually go in naturally.  And I will also take this and let's rotate this into 

position here and duplicate this and store this version here as a "Casing 1 Rotated".  And now I can go 

and perhaps select this casing here or this beam and change it to "Casing 1 Rotated".  And now you can 

see now it flips up into position. [0:10:08] 

The two ones that I had earlier put in for the column - let's go to the Column tool and you should be able 

to select these two columns.  I can just mirror them back now that I have it set up a little bit better.  I 

will just make sure that they are mirrored.  And let's take a look in 3D.  So we now have casings, but of 

course they're not cleaning up to each other.  If I were to select this and use the Stretch option to 

stretch it up to there, we would see that they obviously don't miter at the corners.  If I were to select 

this one and stretch the length of it over towards there, we are going to see them pass through each 

other.  And in fact, that's not too bad because this particular shape, I know sometimes that's not going 

to work very well in terms of having a clean intersection.  But this could certainly in some cases be a way 

to work with it. [0:11:14] 

So I will just stretch this out to there and select this one and stretch it up to there.  And we now have a 

molded casing.  If we want to put that on the other side of the wall we would just select these three 

elements, and we might group them.  And then we can easily go and mirror a copy across to the inside 

of the wall and then move it into position like that.  So now this door, if I were to have the door open 

and we were to look at this, we would see that we have the casing on both sites there.  [0:12:15] 

If we rotate this around we will see that nice casing on the two sides.  So this will be one way that we 

can work with it.  In terms of that clean up, I think we were lucky there.  And it won't always clean up 

properly.  In fact, look at what we are getting at the end here.  This is really not going to work perfectly 

because it's really not mitering; they are just passing through each other.  So let's look at how we could 

work with this on the floor plan, where we can make sure that it cleans up properly and then flip it up to 

into position. [0:12:58] 

So if I go back to the floor plan and we take the Beam tool here and set the Beam tool to be horizontal 

and have - where is the elevation?  Well, we can move the elevation down later.  If we go into the 

settings and say that we wanted to be up at 5/8 inch - because you're going to be setting it to the top 

height.  In fact, let's not use the Beam tool; let's use the Wall tool, because that's actually a little bit 

simpler.  I will go to the Wall tool and take the walls with a profile. And again take that same profile, that 

Casing 1 here. In this case we want to have the casing facing the other way.  [0:13:58] 
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So let me go in here.  We'll go to the Casing 1 and we'll duplicate this before we make the change and 

then mirror it there.  And we will store this new one as "Casing 1 Reversed".  Now if I go to the Wall tool 

and say that we want to use a profile that is going to be the Casing 1 Reversed like this, now we can say 

that it's going to be lying on the ground and we'll just create a shape.  I will go and draw three sides like 

this.  [0:14:56] 

I will go up the 6'8".  And I think this door was 3'.  So we will type in 3, and then go back down to this 

point.  So these three elements are separate elements.  Let me just drag them down into position here.  

It looks like when I did it, it cleaned up to the other walls.  Let me just do it again.  Some let me take it to 

the 6'8", 3, and there.  And you can see how it automatically cleans up.  So in fact, if we were to look at 

this in 3D, we will see that it is cleaning up precisely. [0:15:50] 

Each one of these elements is now mitered.  So ArchiCAD is able to miter the corners when it's all in one 

plane and done with the Wall tool.  It does that automatically.  But I would like to have this standing up 

vertically.  So how can I do that?  Well there's a little trick when you save a library part.  If you orient 

your view differently than you might otherwise, if you look from a certain angle, you can essentially ask 

ArchiCAD to flip it up into that angle. [0:16:25] 

So what I'm going to do is select these elements so they are the only ones that are going to be viewed.  

We say show only the selected elements in 3D.  Then I go to the View menu, 3D View Options, 3D 

Projection Settings, or use the keyboard shortcut for that, and choose a side angle.  Now if we are in 

perspective and we have a whole different set of options in terms of moving the view around, we need 

to be in the parallel projections. Instead of saying perspective, we need to be in parallel.  And then we 

can choose for example the side view and move the camera reference around to 90°.  [0:17:06] 

In this case it's going to be looking from the top of the screen down. And when we say OK, we're going 

to see that we're looking edge on at the elevation of this but from the side that will be the top.  So we 

are going across the top of the wall.  And let's just close up the profile manager here.  So I'm going to go 

now to File menu, Libraries and Objects, Save Selection As - actually I have to select this first.  In earlier 

versions of ArchiCAD you didn't have to do that. If you had nothing selected it would save the entire 

model, whatever was in your window at the time.  [0:17:45] 

But in recent versions, you have to select it first. Then you can go to the File menu, Libraries and 

Objects, Save Selection As, Object. Now in earlier versions of ArchiCAD, it might say Save As...Object and 

then afterwards ask you if you want to do it as a door or window, and there would be a separate 

command if you wanted to create a component like a door leaf or something like that. [0:18:08] 

But in more recent versions, you actually can choose right away.  I want to make this as an object.  And 

when I do this in the latest versions of ArchiCAD, it gives me a little heads up that this view is going to be 

used as the floor plan view of the new object.  So basically, the floor plan view is going to be the top 
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down view of it and it's going to be rotating the object to suit. In earlier versions it did the same thing, it 

just didn't give you that message. [0:18:35] 

I'm just going to say OK and give it a name. We'll call it "Casing 1 for Doors". Something like that.  And 

we're not going to worry about the materials right now. If I go back to the floor plan now and I go to the 

Object tool and click, you can see here is this object.  And you can tell which way the molding is facing.  

It's facing reverse from what we would need here.  So I'll just go ahead and mirror it.  And I will apply 

this to the copy of the door.  For reference, I will drag a copy over and take this element and drag it into 

position.  [0:19:27] 

Now the snap points, when we do it this way, aren't necessarily going to match.  Actually, that's the 

3'x6'8" size. It seems to be the size of the door leaf.  So in fact, this is almost working, but let's just drag 

this over there. And now this side is matching the rough opening but it's a little too long there because I 

really should have make this bigger.  To center this, I'm going to drag it sideways and snap it to the 

center point of the door.  So now it's nicely centered there. But it needs to be dragged so that it is on the 

face here.  Now if I go to 3D and we take a more conventional view, let's say we're in an axo and we 

orbit - in fact I would say we want to show everything in 3D and zoom out and the rotate around. 

[0:20:44] 

We will see that I now have the casing very nicely mitered right here.  So this element is the casing on 

the door.  I made it to fit the door leaf.  You can see how the door leaf, the 3' by 6'8" is the size here.  So 

what I've done is created a version of this out of multiple pieces on the floor plan and then selected 

those, viewed only those in 3D, taken a view from the edge that I wanted to become the top. In other 

words, this is the top view of it. I took a view that made it have that top view. And then it saved it as an 

object.  And so this is an object that I can of course make multiple copies of.  [0:21:39] 

I'll just mirror a copy of it across here, take this copy and drag it up to the other side.  And now we have 

a casing on the other side.  Of course we want to have this jamb here extend through the wall if we 

were to do that.  Or we would want to have the casing go around further to the end of the rough 

opening. So we need to create actually multiple versions of this element.  If we were to select that, I 

could go here and stretch this.  I actually can go and use the option to move the node point and stretch 

it.  And I'll just do it by eye here.  [0:22:22] 

And let's take a look in 3D and turn around.  And we will see that this molding does look just fine around 

here.  But what it actually did was distorted it as I stretched it. I got a little bit wider.  The casing would 

be a different size.  Now that may not be an issue, particularly if it's just being stretched a few percent 

there, but in general what you would want to do is create more than one of these objects.  So you would 

select this, particularly if you were to do a double wide door for example. If I were to select this and 

stretch it wider here, we are going to see that the profile gets really absurdly extended.  [0:23:12] 
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And I'll just undo it and you'll see the difference there.  So what we would need to do is create another 

version of it. And I could use the Marquee tool, draw a marquee around this, and stretch that out to 

whatever size I needed there.  Ideally what you would do is keep one copy with one size, you would 

make another copy of all of these elements and stretch them out so that you have two or three, as 

many different sizes as you needed.  And then the profiles would remain nice and constant. [0:23:45] 

No what I just did here in terms of creating this shape is pretty quick to do, but I think it is a work around 

to the limitations that ArchiCAD does not have ornamental molded casings around doors.  It just doesn't 

offer that as a built-in feature for doors or windows.  And it really should. But this is an example of 

working around a limitation of ArchiCAD, creating something that has the right geometry and shape and 

then turning it into an object and in this case rotating it up 90°.  [0:24:24] 

Now what if we wanted to make this a little more ornate? For example, let's say that we wanted to do a 

plinth block under here.  What I might do is shorten this. If this is 6'8", let me take this to 6'. So we'll go 8 

inches shorter. And again take this and stretch it the same way.  And then perhaps take a little slab.  And 

in this case I will make the slab with a common color here. And I'll make it very thin, say going up to 1" 

and zero. And I'll just draw a box here. [0:25:19] 

Let's say I wanted to take this down 8", and let's just say 3"x8" - like that.  So create this shape there.  

Perhaps I will just make sure that it's the same width, like that, if I wanted that to be the case. And I'll go 

and drag a copy of this over to there.  So now at this point, if we were to look at this shape here and go 

and just say show only those elements, you can see that I've now got a little different shape with a 

plinth block down below. [0:26:12] 

Now if I want to turn that into a library part, then we can go in here and go to 3D View Options, 3D 

Projection Settings. Again select side, rotate the camera up to the 90°.  We are now looking here.  You 

can see the shape that I've got.  And perhaps just select all of these elements and go to the File > 

Libraries and Objects > Save Selection as…Object.  And go ahead and we'll call this "Casing 1 with Plinth 

Blocks". [0:26:55] 

Now, if I go back to the floor plan and then say show everything in 3D and again rotate this around, I 

could either place this object fresh or I could select this and perhaps switch it to the new casing with 

plinth block using this flick button here.  You'll notice that it actually has substituted the reworked object 

here.  So it's very easy now to place them or experiment. [0:27:36] 

For example, I can go back to the previous version here or go to this new version by simply flicking 

through that.  And essentially what I'm doing is in the library part window, I'm going back and forth 

between these different ones that are in the same folder. And you can see that that's what happening 

when I use these flick buttons going left or right. [0:27:59] 
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Now let's look at a little bit more ornate case.  I'm going to bring in an image a gate.  I just dragged an 

image that I found on the internet of an ornamental gate.  So let me just move this down a little bit. And 

this gate here is certainly complex, but relatively straightforward to model if we were to think of it lying 

down on the ground and we were to use tools like the Wall tool to create the shapes; curved and 

straight and different thicknesses.  [0:28:38] 

Now in order to use it as a guide, and may help to resize this so that it's approximately the right size that 

I need.  So I'm going to assume that this gate might be 6' across, not quite 2 meters. 1.8 meters or 

something like that.  So to do that, I will have this selected, go to the Edit menu, Reshape and Resize or 

Command or Ctrl+K. And say that I'd like to do it graphically.  By doing that, I can go in and for example 

click on a point like this, click on another point perhaps staying locked in on the axis line. So you see the 

angle is zero.  [0:29:21] 

And then it says how big or small do I want? You can see the ghost image. But let's say that I just type in 

6'. And what it's going to do is make this distance, the 2 points that I clicked on, to be 6' apart.  If I were 

to measure from this point to that point, you can see that it's 6' distance.  So of course it's not precise 

because this is just a photo, but it does mean that I can draw next to it something very similar. [0:29:52]   

So let me go to the Wall tool. And in the Wall tool I will change this to a simple wall. And we'll make 

these 2" thick and 3" wide here, and we'll have a material. In this case we will make it something like the 

metal that it would be.  So let's just see what would be good here. Here's an iron one that we could use. 

So I'll just draw a box initially. Say that would be 6' across 5' tall. And then I will take this one and curve it 

here.  [0:30:47] 

Sometimes you have to activate the pet palette more than once to get it to take that shape.  So I'll get 

this to be whatever size I want there.  Perhaps I will take this element and drag a copy of it down to 

create that second form there.  Then I will go and take the width of it down to a narrower. And the 

height is narrower here.  And of course we could do a lot of finessing here, but let me just create a single 

wall here and another one.  I will just repeat this.  [0:31:35] 

Let me just take a multiply here. And let's say five copies, distribute it. I'm going to do this really quick 

and simple, like that. And then take these and use the Adjust command to adjust them to this wall.  So 

now they all meet here. So you can see now that I've got something starting to at least suggest that 

ornate gate.  Let me do something a little tricky with the spline.  So I'll go to the More tool here and 

create a spline. And let's zoom in on this a little bit. I'm going to show this layer for the spline. [0:32:34] 

So let me just get that shape cleaned up and then I will mirror a copy of it over. So something like that. 

For our purposes, it is not to be too perfect.  Let's just take this and I'll go and say mirror a copy, 

something like that. And then we'll take this and mirror it like that.  So now I have something that is 

almost working.  I will rotate it around like that. [0:33:34] 
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So now I almost have this going and maybe I will just smooth this transition here. Alright, so now I have 

a shape that's pretty similar to what we see there. And I will use the Wall tool and magic wand this. Let's 

see what happens when I magic wand it. You can see that it traced some things here. These are wall 

segments. It did get a little confused with this one.  What I found is that it traced these two points, but 

put it on the wrong side, so I need to flip it over like that. And then do the same with this one, flip it over 

the other way. [0:34:18]  

And now we have something that actually, if we were to look at this in 3D, you can see it starts to look 

like that ornamental gate.  So let me just go and take all of these guys and we will mirror a copy across 

here. And for now if I just clean this up a little bit - it looks like I missed this one. Let's just take a wall 

here, and we'll take this as a 3 point. That didn't quite work. Let's just flip it over to the other side, that 

will help. And flip this one back if I'm going to go in that order. [0:35:33]  

So now we have something that is not quite perfect, but I think you get the idea.  If I select this here and 

we look in 3D, we're going to see a rather ornate shape.  So guess what? We can turn this into 

something that would stand upright by simply going to the View menu, 3D View Options, 3D Projection 

Settings, taking our side view, taking it up this way. And now we're looking at what will become the top.  

We select everything here, I just did Command+A. And I go to the File menu>Libraries and Objects>Save 

Selection As…Object. [0:36:12] 

And we will call this "Ornamental Gate". And go back to the floor plan and go to the Object tool and click 

to place it. And you can see what it looks like. It's got a top down view. If we were to look at everything 

in 3D now and zoom around - remember, I had placed this way out in front of the building. So you can 

see, this as an object here, whereas these are individual walls that we are creating.  So you can do this 

rather elaborate set of elements and it will become one single one there.  [0:36:59] 

Now suppose that we were creating something that we wanted to tilt, but not 90°. The gate wouldn't be 

a great example, but certainly we could have some type of the casing that we might want to do. So let's 

just take a look. Suppose we wanted to have a casing around a skylight. This is a little arbitrary, but I'll go 

ahead and eyedrop this wall type. And let's just create a box of walls that we might put around a 

skylight.  [0:37:34] 

And I'll just make this a nice even size here, and we will select these elements. Instead of going into 3D I 

am just going to, on the floor plan, go to the File menu>Libraries and Objects>Save Selection As…Object. 

And we will call this "Casing for Skylight".  Now having done that, if I click on the Object tool and click, 

you can see that it's placing something right next to it.  We could go in 3D and say Show All in 3D and 

zoom out. And again as you would expect, this is a wall, whereas this is one object.  [0:29:25] 

Now how would we tilt it? If we have something that we had assembled and we wanted to tilt it, and 

perhaps put it at different angles at different times, here's what we can do. We can select this object 
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either on the plan or in 3D, go to the File menu>Libraries and Objects, and say Open Object or use the 

keyboard shortcut Command+Option+O or in Windows, either Shift+Ctrl+O or Alt+Ctrl+O.  One of those 

would do it. Now it's going to open this skylight casing object here, and we will see that its 3D view is 

represented as you'd expect lying down on the ground.  [0:39:00] 

And the parameters are very limited. basically, there are some built in ones that were created in 

ArchiCAD 16 that are a little more elaborate than some might be in earlier ones. But basically it has a 

certain size here that it's using and the thickness, and that's about it. Not a whole lot of information that 

is there.  We're going to create a new parameter by clicking this New button. And that new parameter 

I'll just call it "rotation_angle". Whatever you put in for the name can't have any spaces, can't use a 

dash, but it can use an underscore as a separator.  [0:39:42] 

And I will type in here "rotation angle". Now this is the name that we are going to see in the library part, 

so it can have spaces, whereas that one is the variable name and cannot. Now the type, we press down 

on this little popup, and we want it to be an angle. The difference is that if it's a distance, it will convert 

between metric and feet and inches if you were to switch, whereas angle is constant. Everybody uses 

the 360° to do a circle.  So I just set it to be an angle.  [0:40:13] 

Initially I will leave it at zero, and this will do nothing in the library part other than adding a new other 

than adding a new little parameter that you could type something into.  But in order to make this 

actually do something, I will go to the 3D script.  So by clicking on this 3D button.  You'll notice that the 

first few lines here are written sort of in English. It says the name of the part, it's written by ArchiCAD on 

a certain date here. Now I can add spaces, I can edit this text if I want. [0:40:45] 

All I really want to do right now it type in the following: "rotx". That tells ArchiCAD to rotate around the 

X axis, and I will type in the name of that parameter that I just added: "rotation_angle".  So whatever the 

name is that I used, I want to put in there.  Now this is the only thing that we need to do for this script.  

If I say "check the script", it'll say it's okay. And if I click on the 3D view we won't see anything different. 

But if I go to the parameters and I change the parameter that says "rotation angle" - I will type in let's 

say 30°, and then click on the 3D view, you'll see that it flips up 30°.  [0:41:27] 

So this is actually now active. I'll make it zero so we can have it back in sort of a neutral view.  Now let 

me go ahead and save this just by hitting Command+S or Ctrl+S and go back to the floor plan. Here is 

this object here. Actually let's just look at these two side by side just in 3D. Actually, let's just go back to 

3D directly.  Here is the object.  I'm going to open it up, and you'll see that there's a rotation angle 

parameter that I just added.  [0:41:57] 

If I type in 30°, were going to see the preview change. And when I go back to the view, you can see it has 

flipped up. So whatever I have created lying down, I could easily tilt it on command.  When I go back to 

the floor plan, it doesn't look any different.  That could be an issue, because after all, if I were to take his 
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element - and make it even more extreme in terms of the angle. Let's make it say 90° here. You can see 

it's going vertically, but on the floor plan, we're not seeing any difference.  So we need to be a little bit 

smarter and put in just a little bit more scripting into the object.  [0:42:44] 

So I'm going to select it again, go to File>Libraries and Objects>Open Object, or I can actually just switch 

under the Window menu to the name of that object.  So all I've done is created a parameter here and in 

the 3D script, I entered this particular very simple line. In the 2D script, we need to do something similar. 

I just have to do a tiny bit of ending.  Now the 2D script has a lot of stuff in here. I just need to go right 

after the initial line and create a blank line here and type in "project2, 3, 270, 1".  [0:43:30]  

You don't have to know all of what this means, but briefly this says project the 2D view from the 3D. And 

this has to do with what angle or what type of view. It's looking straight down. This has to do with the 

camera position. And this I believe means that it's doing it as either as a hidden line or wire frame, I can't 

remember.  But this is the one that we're going to use.  [0:43:55] 

Now I say check the script. It's fine there. Let's go to the 2D view here. And the 2D view doesn't look any 

different than it did before. But let's see what happens when I go to the parameters and I change the 

parameter to a rotation angle of let's say 45° and click back. You can see that there are now two 

versions of it.  There's one that would be a top down view as if it had been flipped up 45°, and the other 

is the original symbolic representation.  [0:44:27] 

Now we probably wouldn't want both of these in there, so we are going to go back to this 2D script and 

do one tiny thing, which is after this line go to a new line and type the word "end". And what that does is 

it says, "just give me the projection. Stop right there. Don't do any of this other stuff."  Now when I click 

here, you can see that it's only giving me the view that represents the top-down view.  So I just hit 

Command+S or Ctrl+S, I go back to the plan, and you can see it's showing a top-down view. Remember I 

flipped it up to 90°? [0:45:03] 

I'll just go in here and say what if we had it at 30? It's going to be almost closer to lying down. If I go back 

to 3D, we will see that here is the 30. And if I were to select this and change the angle to zero and have 

it lie down, and we go to the floor plan, it does look much the same.  So this is the simplest way. It's not 

using all of the tools that ArchiCAD has for controlling the angle and being able to manipulate it and 

snap to it in 3D, but it will work for the basics.  [0:45:43] 

So if I undo this so that it's still rotated up, you'll notice that the hotspots are actually only on the plan, 

we don't actually have snap points up here. So that would be something that would require more GDL 

knowledge to be able to have that work, but for now this allows me to have a model that shows up 

beautifully in 3D with a controllable angle and shows on plan properly.  [0:46:15] 

In the old day, meaning before a few versions ago, when we would put a car on a roadway and the 

roadway was tilted, this was a way to save an object like a car as a new object and add in a parameter 
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that would tilt it in the right orientation. In recent versions of the library, Graphisoft has put in a 

parameter so that you can actually make a car tilt and match the roadway. So that is not necessary for 

that. But perhaps you will find some use for this purpose.  [0:46:51] 

Now in closing, I want to show one last thing, which is a trick. If you have ArchiCAD 16, we have the 

Morph tool as you know. What I'm going to do is select this group of elements, these are the walls. And I 

will drag a copy of them over to the side.  Now these elements, if I go to 3D and say just show only these 

elements in 3D, and we were to select them like this, one of the commands we have in ArchiCAD 16 

under the Design menu is to Convert Selection to a Morph.  [0:47:33] 

When we do that, it changes all these walls.  Remember this is not an object; this is just a bunch of little 

walls. It's going to be converted into one or more morphs.  When I do that and select it, you can see that 

it says this element is morph, that element is a morph, etc. It doesn't look any different.  For 

convenience, I'm going to select even as a morph and go to the Edit menu>Grouping and group them 

together. [0:48:02]  

Now having done that, one of the nice things about morphs is that you can actually go and rotate this in 

3D space.  So if I go to the corner here and say rotate - now rotate normally would rotate things around 

the floor plan. So I can rotate it around here. This basically rotating it on the ground.  But that's not what 

I want. I am going to use that same Rotate Command here, but if I go to the edge, any edge, you'll notice 

how the compass, which is the preview, changes to something perpendicular.  [0:48:39] 

So now that's saying, "maybe I'm going to rotate around this plane". So when I do that, now I can say 

take this axis line and take it up to the other axis line, and I've now flipped this up directly.  So this is still 

a set of morphs.  It's not an object.  You can see it's fifty-four little pieces here that happen to be 

grouped. But instead of creating an object, I can - if it's a morph or I convert something to a morph - I 

can literally just rotate it in space. That is really cool.  [0:49:13] 

If you are going to use the Morph tool like this, you might very well want to combine these elements 

under the Design menu. If I go to Modify Morph here I can go do "Union". And what that will do is 

actually join all of these into a single morph.  If I select it now, you can see here is a single morph 

element as opposed to all of those.  I wouldn't have had to group it in that case.  [0:49:37] 

But you can see how rotating it in space I can do it has a bunch of separate morphs or of course it would 

work the same way if it was a single morph element.  So on the plan it's showing - now remember these 

were walls and I converted them to a morph and I flipped it up.  This is now a single morph.  Here are 

the actual spline elements, the 2D stuff. So they didn't actually get converted, but of course the walls 

that were mimicking them or tracing them did.  [0:50:10] 

So this concludes our lesson on rotating and tilting objects that you create, basically modeling things 

that are little bit easier or have more flexibility or power to draw them on the plan; and then flipping 
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them up by converting them into an object that then becomes, in this case, elements.  So here, actually, 

have the ones that were beams and columns. This is using the fill to create a complex profile. But in this 

case over here, I was creating an object that became the casing or the casing with a plinth block there.  

And then I showed the variations with the ornate gate here, where I essentially did the same thing, just 

create a more complex model and then saved it as an object with it oriented it in the vertical position. 

[0:51:14] 

And then finally I showed variation which you can do in ArchiCAD 16 which is to convert these elements 

to a morph and then you can literally just rotate it in space.  So this has been Eric Bobrow.  I think this is 

really quite amazing what you can do now in ArchiCAD, now that you have these skills, you are going to 

be able to model a lot more things more easily. Please add your comments and questions to the page 

down below. I look forward to reading them.  Thanks for watching.   

[END OF AUDIO 0:51:51] 


