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BEST PRACTICES COURSE – WEEK 21 – Creating and Customizing 
Library Parts PART 1 - Creating Basic Objects; Optimizing Handles, 
Adding Parameters 
 

Hello, this is Eric Bobrow.  In this ArchiCAD video tutorial, I will show you how you can create your own 

custom 2D symbols or 3D library parts, and how you can optimize and fine tune them so they have 

selection handles that make it easy to precisely placing into your model.  How you can add intelligent 

controls for let's say text so you can have text with a symbol that changes as you need it each time you 

place it, and even the size of the text can be adjusted. And how you can take any combination of 2D and 

3D elements and create a compound object, a new one that will have all the information you need for 

placing it into a schedule an appliance or equipment schedule that has all the listing parameters just like 

the standard library parts.  We'll be going through a little bit of GDL editing, but I promise you, it will be 

very easy to follow and you will be able to get a lot of mileage or a lot of value out of some very simple 

modifications that I will show you.  Are you ready to get started?  Let's go.  [0:01:13] 

So let me just draw a box of walls here, which will give us some context, and zoom in on a corner like 

this.  I'm going to create a 2D symbol first. I will just use the Line tool and draw a simple line here.  Then 

I'll go and create an arc.  Now I have something that is a symbol.  Let's make it a little bit more 

complicated by putting in some text. So I'll just click where would put the text in, click twice, and type 

some letters.  Now I would like to center this text, so I'm going to drag this. And when I drag it, I will 

move it horizontally, hold down the Shift key to lock it, and then snap that center point in line.  So now 

it's nicely centered.  [0:02:08] 

Now if I were to add more text to this, it's obviously losing its centered attribute.  So let me undo that 

and show you how you can maintain the text even when you change how much text there is.  We can go 

and make the text centered from one line to the next and anchored by the center midpoint here.  Now 

having done that, if I were to put in some more text, you can see how it is staying centered right over 

the point that I placed it.  Let me just drag this up a little bit so we have it nicely placed within the 

symbol that I'm creating.  [0:02:52] 

I'm going to go to the Arrow tool and select all of these elements here. This is the line, the arc, and the 

text element.  Go to the File menu, Libraries and Objects, Save Selection As, Object.  Now in earlier 

versions of ArchiCAD, it may say Save Selection As Object, and then later you choose Object or Window.  

In more recent versions it asks you right away what you want to save it as.  So I will save it as an object, 

and call this "New Symbol" here, and it will go into the embedded library within the project or I can save 

it out onto my hard drive in a folder.  So I'll just say save this.  [0:03:33] 

Having done that, it then says, "Do you want to customize the pens?" I'll just leave these alone. This 

would allow us to change the pens later. This is a new feature in ArchiCAD 16 or maybe it started in 15, 
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which gives us some more options, but we don't need to look at that now.  Having done that I'm going 

to go to the Object tool and simply click, and you can see that it's placed an element next to the original 

one, but it's a single element.  You can see that it's got a set of hotspots, it's an object, and when I open 

it up you can see it says new symbol and here is what looks like.  [0:04:07] 

Let me just close up some of the panels here so see you can see everything.  Now, I'm going to show you 

how you can create a 3D element just like this.  I'll go to the Wall tool and instead of drawing a box of 

walls, I will just draw a single wall, and I'm going to make this sort of as a backing. I'm going to make a 

little object that is sort of a stand that you could attach to a wall.  So I will make this very short, say 1 

foot, which would be about 300 mm, and only an inch thick.  And I will just lock the materials for all of 

them to something like a paint color. Say paint 14 here.  [0:04:53] 

Now I'll go and draw this piece of wall, I will make it a short little piece here.  So this is a simple little 

piece that I'm now going to attach or model something in front of.  I'm going to use the Slab tool. And in 

this case I want to take it up above the zero, so I'm taking it from 0 to 1. And again I'm going to go lock it 

so that it's all one material. And let's take this as a different material here.  Then I will draw a rectangular 

box. And let's say that I wanted to make it 1 foot along by 8 inches here. So now I've got a little 

combination of two elements.  If I look at these in 3D - actually, if I just bring up the 3D window, we will 

see those elements right here.  [0:05:54] 

Now I'm going to go ahead and save these the same way I did before.  I'll just select them on the plan 

and you'll notice that there are two items selected. The wall actually has its reference line along the 

edge of the slab. I'm going to go to the File menu, Libraries and Objects, Save Selection As, Object. And 

let's just call this "Wall Stand". You'll notice that it's bringing up that similar dialog which was introduced 

as I said in ArchiCAD 15 or 16. And I can save the material for the blue, I think that was the base material 

and the material for the back is this one. When I am typing this in, when I'm working with the later, I will 

be able to see which these refer to, and I could change the materials. Let me just say OK. [0:06:48] 

Now having done that, go to the Object tool and I can place it.  So that works nicely. If I go to 3D you can 

see I have the two near each other, this one being a single object and this one being a set of two 

elements, wall and slab.  Let's say I wanted to refine this. So I'm going to go here and fill the corners, 

make it curved.  So now we have a shape that a little bit different.  I will go here and select these two 

elements, repeat the exercise, save it as an object. And I could either save it as a new object or if I type 

in carefully the same name, then it will ask me if I want to replace it. When I say replace - and of course I 

may now have to repeat this, this was base material, and back material here. [0:07:56] 

But you'll also see that after I refresh the screen and zoom in or out that the object here has updated.  

So in other words I overwrote the original one, and any instances that were placed have already been 

updated.  Now you'll notice that the hotspots remained square here. And in fact, on the original object 

like this, they are square. And perhaps we want to have a hotspot in the center point here, and we don't 
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want to have these hotspots sort of hanging out in space.  Let me show you how we can edit this object 

to make it a little bit smarter.  I'll go to the File menu with this object selected, go to Libraries and 

Objects, and Open Object.  So open object if I have nothing selected it will allow me to browse for one 

within the library. If I have one element selected it will open it directly. Having opened it, it brings up the 

dialog box here. And what we are going to see is that there are a lot of different buttons and places that 

you can click on.  [0:09:01] 

If I go down to 2D here we will see that text that says the ABC 123.  Let me just change that here. 

Remember that's what I had typed in before. I will just change it to XYZ and say Save. And I just did 

command S or Control S, and you can see how the object has updated.  Now let me go back and open 

that or look at the object again. It's available under the Window menu, and you can see the name of the 

object "New Symbol", that will bring this right back up.  But let's take a look at the section called details. 

[0:09:33]   

Now in earlier versions of ArchiCAD it may be that you might see parameters and then at the top 

something about details. In more recent versions there's a separate little button here. When I am in the 

details there are different things that I can change, but the one I'm going to look at right now is 

compatibility options. And we can see that there's an option here to put hotspots on the bounding box. 

That is what's giving those hotspots, those ones out in space.  I'm going to cancel this here and close the 

object because I'd like to overwrite the object with hotspots that I carefully place myself.  [0:10:10] 

So I will just save it, and then close it here. Having done that, what I'll do is go to the Hotspot tool. This is 

under the More group of elements, and I will go the Hotspot tool. The hotspot, as you probably know, if 

I click anywhere it puts a little X and when I hover over it I get a checkmark just like I get a checkmark at 

the corner of things.  Now I'm going to undo that and place the first one where I would like to be able to 

insert this object.  It could be any point I wish, but perhaps I want to put it in by this center bottom point 

as a primary one.  I will also click on the other ones that I think are useful here and perhaps where the 

center text is.  [0:10:54] 

Now having done that I'm going to go ahead and select all of these elements again and go to the File 

menu, Libraries and Objects, and we'll say Save Selection As, Object. If I wanted to I could overwrite the 

one that I had before, but let's just create it as a second one here. I will just leave this alone; I don't need 

to worry about the pens setting here. And I will go back to the Object tool. And the object tool has 

already been set up to place this new object.  I'll just click and place it.  You can see now when I select it 

that there's hot spots in - let me just move over a little bit - on these extra points.  In fact, let me just 

drag this down a little bit to get it clear.  And if I compare that to the original object which only had the 

four bounding box ones in the center, this new one has some additional hot spots here. This center 

point, the top here, and another one for the text.  [0:11:53] 
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Now me go and open up this object.  There's a shortcut for doing it. If I go to the File menu, Libraries and 

Objects, Open Object, there's a shortcut. On Mac its Command+Option+O; on Windows I believe it 

would be Shift+Ctrl+O, but you can look and figure that out for yourself. Now if I use that keyboard 

shortcut it opens it up. And let's go to the compatibility options and turn off the hotspots on the 

bounding box and say OK.  And then save that. By the way save here saving this object, not the whole 

plan, just what's the current window, and if I go back to the floor plan you can see that the change has 

taken place. [0:12:36] 

Now remember that this text was what I had saved it as here and I had manually changed it in this one 

to just a different fixed text.  So you can make the text whatever you want before you create it or 

afterward. But what if you wanted to put it in sometimes with one text sometimes with another, or just 

make it totally parametric?  So let's open it up, I've got the object selected, Command+Option+O or 

Shift+Ctrl+O, and let's take a look at the 2D script. And what you'll see is that there is some text in the 

middle of it that has the "ABC 123" in quotes.  So that is what's causing it to have that text.  I'm going to 

replace it with a parameter.  [0:13:23] 

So I'll go to the Parameters section of the library part and create a new parameter.  So I create a new 

parameter it gets added to the list, and I'll just give it a variable name. Now this is a name, let's call it 

"textcontents".  You can't have any spaces in it; it has to be all connected.  And we have a type. The type 

in this case is going to be text.  So I'm going to use this little popup for the type and choose ABC which 

indicates text.  Then whatever is shown here is going to be seen when you are opening up the object, 

the object settings, when we place it.  So let's just say "text contents". This can be multiple words; it's 

really for you as a human being or designer when placing it.  [0:14:13] 

Now what's the initial value?  Let me just put 12345. So whatever I put in here will be the default when 

we switch to that object.  So we'll probably want pick something that will be useful. But I will just 

demonstrate this content here.  Having done that, this parameter is now available, and I switch to the 

2D script I could replace the text here including the quotes with "textcontents".  So basically that same 

word that I used in the parameters here. I could even copy this here and go and delete it and just paste.  

You can see I can actually paste it in. It's just on a line by itself. [0:15:00] 

And when I hit save here, I just did command S, and I go back to this, you can see this is switched to the 

12345, but unlike before, now under the parameters, I can switch this to any text.  So let's say ABCDE. 

And you can see how that switches up above here and when I click OK it will switch on the plan.  So now 

we can actually have text that can vary, put it in once with one text, put it in another time with another 

text.  [0:15:35] 

This concludes the first section of my three part ArchiCAD video training on creating custom library 

parts.  In the next section, we will look at how you can make these 2D symbols smarter, so that the text 

can be adjusted in terms of its size parametrically, as well as having more than one line of text.  In the 
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final section, we will combine 2D and 3D components in a more complex way and create compound 

elements.  Then we'll make them smart enough to pick up the object ID from the info box as the text on 

the floor plan and also change their subtype so that they have all the listing parameters necessary to fit 

into standard interactive schedules such as an appliance or equipment schedule.  This has been Eric 

Bobrow; please add your comments and questions to the page down below.  If you like this video, 

please click the like button or add a comment and let me know what you thought.  I look forward to 

reading your feedback.  Thanks for watching. 

[END OF AUDIO 0:16:37] 


