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Hello, this is Eric Bobrow, and in this lesson we'll take a look at some of my favorite approaches for
drawing and editing directly in the 3D window. Here we have a totally blank drawing. If | bring up the
3D window, it's sort of hard to know where we are. And while | can draw let's say a box of walls here in
3D space, | don't really know where they are, and | don't have any context. But still, the tracker is in
there, and if | wanted to make something a certain size, let's say 30 feet long by 20 feet wide or
something like that, | can do that. [0:00:38]

When | go back to the floor plan, it may be in a surprising location. Now once | have some context here,
then it does become a little easier to draw. So for example, if | orbit around - and by the way I'm using
the keyboard shortcut that | use all the time for orbiting, which is to press down the center mouse
button to get the Pan tool and then press the Shift key at the same time. And then you can orbit right on
the fly, and let go, and I'm actually back in editing mode. Now in 3D, | can easily go and draw something
and snap. So for example, I'll just draw this wall, and I've snapped it cleanly to the other wall. [0:01:18]

Now in ArchiCAD 15 we do get guidelines in the 3D window that can show up; so it makes it easy to stay
on the axis. But even in other versions, if we press the Shift key down, it will constrain the angle to the
nearest known one which makes it relatively easy to follow on an axis. And of course we can type in a
value here. Now if you have the Shift key held down, then instead of just typing a number, you may
need to type D for distance or R while the Shift key is held down to highlight that. Then you can let go.
The angle is still locked, and | can type in for example a distance here. [0:01:57]

Now, if | want to make this let's say, this next piece of wall line up with the other one, again | can go
along here and | can press the Shift key down and hold it while | use the constraint and snap it directly to
the other end. So, it's very possible to draw a lot of things in 3D. Once you have some context, you can
easily line things up. And if | get rid of this piece of wall here, | could certainly stretch - select one wall
and this other wall and do an operation like the Intersect command, and that will work beautifully in 3D
just like it would on the floor plan. [0:02:36]

Now if | select these elements here, so I'll just go to the Wall tool and select all by doing command A or
CTRL A, | can change things. I'm in the 3D window, but | can change the thickness. Let me just make it
really thick. You can see here I've made them much thicker or perhaps thinner. So we can type in values
here, | can change the height to any height | want, and that will automatically take effect. So in 3D, we
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can make changes. We can also change the composition of it. For example, | can change the fill here.
Now we won't really see a change in 3D. If | just change it to another type of similar fill, just a mono-
element fill; but if | do change it to something like a composite structure, what we're going to see is that
the wall will get as thick as that composite is defined to be. [0:03:29]

So if | pick one that is relevant here, | can do that right in 3D and it will affect that. And of course, we
can select things and change their material. So | can go ahead and make the outside a red color, things
like that. So there's a lot of editing that you can do it directly in 3D as part of the model making. Now
some of the other commands that we can do involve manipulation, where we are snapping to elements.
And it's really good to get comfortable with this and versatile so you can get the effect you want. Let me
just undo back some changes here. Let's take this down a little bit. [0:04:09]

Now let's say that | wanted to do a roof. We can do roofs in 3D, and | will demonstrate that a little later
in this lesson. But let's just say that | wanted to make a simple roof, say going perhaps from this point
here - we'll take it as a single element roof. This would be the way that you would work in ArchiCAD 10
through 14. And for purposes today I'm going to, even though I'm in 15, I'm going to do a single plane
roof that is just a regular piece. So it'll be a shed roof that will go up this way, and | will just draw a box
let's say there. [0:04:45]

Now if | go to 3D, we're going to see it's rather steep. Now we can go and change its settings in a variety
of ways. For example, it looks like this is a little too low, so we could change it from the 9 feet plate
height to the 10 feet. Type that in, and that will work. But sometimes instead of doing it numerically
here - and I'll just undo that change - | can press down on this and move it up or down. So the pet
palette of course works in 3D, and | can grab the point that | want and snap it. And you can see how it
changed the height there. [0:05:21]

Now the reference plane that we were seeing, the editing plane, is an option in ArchiCAD 15. | can turn
it on or off with the View menu, 3D View Mode, Editing Plane Display. So I'll turn that off right now, and
then I'll return to that little later to show you some of the ways that it works. But if you find that it gets
in the way, if you're not used to it in ArchiCAD 15, you can turn it off under the View menu, 3D View
Mode, Editing Plane Display. You can turn it on or off, just like you can the grid, turning the grid visibility
on, let's see grid display right here, which is for the plan. [0:06:04]

Now let's say that | wanted to change the slope of this roof. Again, | can just type it in a new value like
this, and it will update. Or | can go to the endpoint. And roofs have the special control at the end of the
pet palette here to actually change their slope on the fly. So | can do this to any slope that | want, or |
can just do it by eye. Now, if | wanted to make the walls go up to meet that roof, of course | can select a
wall and change its height using the pet palette, telling it to go up perhaps to meet the top or to meet
the bottom of the roof, either one, depending upon what we need. [0:06:46]

Now it hasn't actually trimmed it, right now they're overlapping. So we would want to connect those
elements. In general we would want to clean up so that they are not passing through each other. But
what happens if we have several walls selected? We want to affect all of these at the same time. In
many cases, we can go select multiple ones with the Shift+click, press down and use this option to
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change their height, and they will all change at the same time to this. Now in some contexts, and | think
earlier in ArchiCAD, it might not have worked quite as smoothly, but certainly that's nice to be able to
select a bunch of elements, change their high interactively. [0:07:25]

Now all of these elements that I've got selected I'd like to trim to the roof. Now to trim to the roof, we
can use the Design menu and do the command that in ArchiCAD 15 is called Crop to Single Plane Roof.
And in earlier versions it was called Trim to Roof. And what this is is a static cut that says, do | want to
cut the base or the top off of one or more walls? And it will look for any roof that happens to be above
it. It will crop or trim depending on which version of ArchiCAD and they're done. Now the limitation
there is if | do change this slope for example of the roof again and take it lower, these walls do not
adjust. And if | were to take it up higher in the same way, again they won't adjust, we'll have a gap.
[0:08:10]

So if | want to have them connect and be smart about it, then | would want to select these. And instead
of doing the crop command, I'd want to go to the Design menu. And in ArchiCAD 15, is under the
Connect menu, Solid Element Operations. Or in earlier versions it would be directly under the Design
menu. But Solid Element Operations would allow me to choose that the elements that I've got selected
are targets. So that means these four walls are targets. And | will in this case select the roof as the
operator and tell ArchiCAD that I'd like to subtract wherever they intersect and everything above. This
would be the same thing. You can look at the little icon here. [0:08:55]

As the roof trim, except it will be a dynamic relationship. So when | execute this you'll see how that is
cleanly done, but if | do take this roof and | were to take it down, you'll see how the walls trim
automatically. So getting comfortable with Solid Element Operations and with the editing right in the
3D window means you can start using ArchiCAD or increasingly use ArchiCAD as a sketch tool, as a
design study tool. Maybe not necessarily being precise right now, but just working out some ideas. You
can still make it very clean, but you can do it by eye, which is a really great opportunity to use your
design sense in 2D and 3D equally. [0:09:40]

Now if we wanted to put something along the edge of the roof, let's say that | wanted to put a gutter
here. Now | could calculate what height that would be. If | select the roof and we look, it's got a certain
height here. In fact let's just check. This is a little bit odd. It was starting at 10 feet and it's changed.
Now remember | adjusted the slope here. Well | adjusted the slope by the top, and it looks like it
actually changed the base here. This is sort of an odd thing that I'm seeing. And I'm not quite sure why
that happened. Let's just say that | take this roof and | tell it to move it down until it snaps. Let's see,
there's the snap point here, and you can see that it's now moved down to the 10 feet. [0:10:31]

So frankly I'm not quite sure why the roof adjusted its height definition, but when | did that | wasn't
paying close attention. But definitely if you adjust the roof slope interactively, you will want to make
sure that you keep your reference height at whatever elevation is appropriate. Now let's say that we
wanted to put the gutter or eaves trough there. Now the roof has a certain thickness, we can calculate
this if | wanted to put it along the top edge. But sometimes | find it easier to just place something on the
plan and then just elevate it. In other words, not worry about its height at the beginning. [0:11:10]
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So | will go to the Object tool and open it up and search for library parts here. And | will type in "gutter"
and hit the Find key; or hit Enter in some cases will work depending on which version of ArchiCAD
you've got. And | will pick "gutter" here. So the gutter allows us to create different shapes. I'll just use
the standard one that they've got. And I'm not even going to worry too much about placing it correctly;
I'll just say alright, that looks like a starting point here. So I'm going to place this gutter just on the floor
plan, and then we'll see what height it needs to be at. [0:11:46]

So if I click to place it and we go to 3D, we're going to see that it's sitting on the ground. So I'll go and
select it and I'll just elevate it right on the fly. I'll go press down on any one of these points here and
then use the pet palette option to elevate. When | do that, | can do it by eye here, or if | zoom out a
little bit and do the same thing and repeat the elevate, | can actually snap it directly right into position
here. Now, what do we get? The height is correct, but actually it's not the right location on - it's not
right next to the roof. So | can go here and say | want to move it sideways and perhaps either use the
guideline that shows up in ArchiCAD 15 or the Shift key to take it straight, and then snap it to the end of
the roof. [0:12:38]

Of course, | could've simplified my work a little bit had | just moved it to the edge of the roof to begin
with. But | did that in 3D, and sometimes that's good. Just move things around in 3D, snapping just like
you would on the floor plan. Now the angle here of the hangars, if we zoom in on this, is not quite right.
These hangars are floating a little bit off of the roof. They are set as a parameter, and | need to know
what the slope of the roof is. Now remember the roof in this case was just sort of moved arbitrarily, so |
don't know what that slope is. So I'm going to select the roof, and I'll look at the slope. [0:13:17]

Now in the U.S. library, the hangars are set by a slope of so many feet over 12 feet. And so this is the
amount 4'8" here. If | were to copy that, and I'll just do Command+C, | can copy it. You can see the
degrees or the percentage are also available here in ArchiCAD 15. In earlier versions, | think you have
those options within the roof dialog box here for different measurement styles, but in the info box |
think they've improved that for - in the U.S. version anyway, there's more flexibility than there used to
be in the Info box. [0:13:57]

Now I've copied that, and let me go and select the actual gutter, and we'll go into the parameters for it.
And you'll see there under the gutter there is the roof pitch. And so this is what it's supposed to match.
If I type in or paste in that value and say OK, you will see how these just slid down a little bit. So now
they're precisely along the right point. Now the roof gutter, | can select it. And of course it needs to be
longer, so I'm just going to go and stretch it and just make sure - actually, | may need to zoom in on this
to make sure I'm grabbing the right point. Grab this endpoint - okay that's not giving me the editing
option. [0:14:42]

Now sometimes | may need to be in the Arrow tool or Switch tools to do that. Let's see, if | select it here,
now | have the option to go and move this point around. So instead of moving the whole element, | can

move just this point, which in this case would change the length. And we'll just zoom out a little bit and |
will snap it directly to the end here. So what | find very convenient is to just quickly put in a concept, put
in this gutter anywhere and then move it into position and stretch it to fit. So | don't worry about
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getting everything right at the beginning, | take my concept, see if it's going to fit, and then adjust it as |
go along. So that can be very powerful. [0:15:27]

Now here's another way that you can get feedback in the 3D window for some of these things. So let's
just take this little mini-building so to speak. And say that | wanted to do a room that had a ceiling at a
certain height. So let me go and put a wall across here like this. And if we were to do a cutaway of this,
and say show just the selection in 3D, we can see the height of things. Now I'm going to go and select
this wall and | will stretch it up. Now when | stretch it up, | could try to make it just the right height
here. And in some cases | may be able to snap that into position. In this case, it actually showed, and |
will show that again, that | had an intersection. You can see this little intersection snap which is just
perfect. [0:16:29]

Now in this case it's going to have a gap, so what | really want to do is take it up higher and trim it using
Solid Element Operations or Connect. So I'm going to go to the Design menu and go to Connect. And
here I'll just say that | want to use the - | want to trim the elements to the roof or shell which is different
than cropping. That's the new term. Trimming to roof or shell it will look - and then it says which roof
do I want? It says, "Click an element to use as a trimming element". | will click on the roof, actually it
didn't like that, let's try that again. Maybe | have to be at a different angle. So I'll go to the Design,
Connect, Trim Elements to Roof or Shell, then | will click on this roof. And it is basically is asking me
which part to keep from the element. So | want this lower part. There is no upper part, so that is clearly
the part that | want to keep. [0:17:23]

Now this has the same type of enduring effect as we would have with the Solid Element Operation. So
I'm going to undo this and show the same thing. If | go to the Design menu and bring up the Solid
Element Operations, which would be at the main level of the Design menu in ArchiCAD 10 through 14,
then take his element and make it the target. Then take the roof and make it the operator and do that
same subtraction with upward extrusion that | had before, and execute. And we'll get the same
relationship here. Now suppose | wanted to have a ceiling that was just at this height here. This height
is a little bit hard to note. In other words, it's just whenever they happen to intersect. Well here's what |
can do. [0:18:06]

I'm going to go back to the floor plan and draw in a slab. And let's just say that I'll put it on the ceiling
layer here. And I'll go and draw this here. Now if | go to 3D, we're going to see that it was drawn at
floor level. But | can easily go grab this point, tell it to move up and snap it. But see if we can snap this
to the intersection here. Oh no, we don't have a snap. So | can move it sort of in the area, but we don't
have a snap because it’s a virtual relationship. But here's what you can do to get it precisely positioned.
I'm going to go and draw a section. Even if | don't necessarily want a permanent section in this area, |
will draw a section for temporary construction use and open it. [0:18:57]

And when | do that, you can see here's that ceiling, and | can go and use the option to move it. Now |
could move it horizontally; reposition it in some way. But what | really want to do is just move it up and
down. So | just move it up until it finds the intersection point, and this is now going to be a totally
precise, clean position there. So I'm not sure about the actual construction of this in terms of a real
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building, but clearly there are times when you want to draw a section and just move something up in
space or down in space until it meets an intersection of the elements. [0:19:38]

Now you can do other types of editing right here in the section. For example, | can take this wall, take it
up higher to any height, and then trim it. So I've brought it up higher than it needed to be, and then |
can use the option again under the Design menu, again either Trim Element to Roof or Shell, or the Solid
Element Operations, and then it will ask me to click on the roof as the element that I'm going to use for
trimming and then say what part of the wall that | want to keep. So | want to keep obviously the lower
part here. [0:20:11]

Now these are joining in terms of their - there's no line work there, that's because the roof as well as the
walls are being drawn with a fill. It's just background fill, a white area. Now | can make this air space for
example, and now it looks the same. It's still white, no fill there. But it's drawing a line. And that line
will be totally clean as | get there. Of course | could also take that roof and make it have a shade, 25% or
something like that. Or | could select it and make it some real composition, perhaps go and make it
some type of a composition that would be appropriate to roofs here. And you can see that that actually
changed its appearance. [0:21:01]

Now we may find as the roof gets thicker or changes that we need to adjust other elements, but right
now it looks like this element here is precisely meeting exactly at the maximum point that we could have
it fit into this area. So being able to draw or using a temporary section, even if you didn't want a section
at this exact point, would allow us to move these things up or down. Now let's take a look at some
things that we have in terms of putting in - if we wanted to put in some moldings, things like that. So let
me just get rid of that marquee. [0:21:44]

So I'm going to go to the Object tool, and instead of having a gutter, let me go and find let's say a
molding. So is spelled M-O-L-D-I-N-G in the U.S., even though it would be with the U in other areas. So
I'm going to pick a straight molding here. And when | do that, | can pick a variety of different styles for
base, crown, different ones. I'm going to pick one here that's a little more ornate. And again I'm not
going to worry about its height. I'm simply going to place it and then move it into position. So you can
see that I've got this molding here. I'm going to go and drag it along here, drag this point in to the
corner, and now I'll be able to see it in the section and move it into position. So if | open up that section,
we should see it. [0:22:38]

Now there it is. | do obviously need to bring in, but it also needs to be mirrored. And so let me just show
you how we would do that in 3D. We can do things in section as well. But in this case, | might want to
mirror it right here in 3D. So if | select this and | rotate this around, maybe get a view looking down on it
a little bit, and now | can go and let's say that | want to move it and mirror it. I'm going to mirror it
across its own axis. So I'm going to go and click on these two points. And it looks like - actually, what do
I have? It looks like | have a wall as well selected. So let me deselect that. | need to make sure that I'm
just selecting the molding and then do the mirror. [0:23:29]

And now you can see the feedback visually makes a lot more sense. | was seeing a whole big element
moving, that caught my eye. So we want to make sure that this is working. So now that molding here is
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of course buried into the wall. If | go up a little bit you can see how it's sitting in the wall. But | can
literally go and grab this and just say | want to move it horizontally and snap it along here. So |
encourage you to get really comfortable with being able to move things and mirror and do things right in
3D, because you can stay in 3D and really quickly work on a model that way rather than having to flip
from one view to another. [0:24:12]

So if I now take this up and say that | want to move it here, now I'm taking it up and right on the fly
while | am doing that, I'm going to orbit and get underneath this. And so now | can see and snap to the
corner of the ceiling. And you see now of course that this molding is fitting in precisely in that location.
Now sometimes, it's a little hard to see in the shaded view. You may want to switch in the View menu,
3D View Mode, and put into the Internal 3D Engine, and then you can see how it's actually a little bit
easier to make out. When | rotate around in a complex model, it will take more time to redraw, butin a
simple model of course the computer can keep up easily in both modes. [0:25:01]

You may want to also want to go in the 3D view mode even if you're in an open GL and adjust your sun
position. So if | go to the View menu, 3D View Mode, 3D Projection Settings, | can perhaps go and rotate
the sun around to be in an angle that would illuminate this particular area better. When | say OK, you
can see now it's lighting from behind me, and giving me more light to be able to see it. So those are two
options in terms of just being able to see what you are doing better in this mode. [0:25:34]

Now | could then stretch this in 3D if | wanted, if | said Show All in 3D. Now I'm able to see this whole
room. And | can for example select this and perhaps tell it that | want to move this point - let's see, |
grabbed the point that is changing the height. | grabbed the lower point. So what | may want to do is
rotate around in here and make sure that I'm grabbing the point that is along the edge. And then when
I'm moving it, I'm actually going to be able to pull it along in a straight line until it snaps. And you can
see where that's done. [0:26:13]

Now of course | could have, if | undo this and go back to the floor plan, | could've stretched this along
the floor plan. And there's nothing wrong with switching back and forth and doing it there. But | just
wanted to show you that you can get just as equal control in 3D in many cases. So being comfortable to
work in 3D, being able to orbit right on the fly and switch modes and do all of these things is very
powerful. If | go back to 3D, sometimes you may want to just hide certain elements. In other words, |
want to focus. Let me just undo this change and let's go back to the 3D. So one of the things you may
want to do is say | only want to see this element and these elements here. So | can right click and I'l
Show Selection or Marquee in 3D. And in 3D now it's going to show me just those elements. Which is a
very, very powerful thing. So now, | could go in and really just see what I've got, stretch this along into
position. [0:27:22]

And then later | can come back and say Show All in 3D, and now I've got my context. So that's really
important to know that you can switch what you're seeing in 3D right on the fly. So we'll finish up this
video here before it gets too long and continue the lesson presentation on 3D editing techniques in the
next video. What we've covered so far includes selecting elements and editing them directly in the 3D
window with the pet palette, orbiting and moving around very freely while working, turning on and off
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different elements to be able to see the model area that we need to focus on more clearly. And then |
showed you how | prefer to place elements off at an arbitrary height and move them up into position in
3D, rather than trying to figure everything out ahead of time. [0:28:12]

We also spent some time looking at ways to join walls to roofs and to make sure that the section cut
shows a line between them properly. And in fact to use temporary sections as well as normal working
drawing sections as a tool for placing elements to move them into the proper heights for example.
Please add your comments and questions on the page down below. This has been Eric Bobrow, thanks
for watching.

[END OF AUDIO, 0:28:40]
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